DataStax drivers 

A list of the available drivers for DataStax Enterprise and Apache Cassandra, plus driver compatibility tables.

The DataStax drivers work exclusively with the Cassandra Query Language version 3 (CQL3). Use these drivers in production applications to pass CQL statements from the client to a cluster and to retrieve, manipulate, or remove data. The C/C++, C#, Java, Node.js, Python, and Ruby drivers support Cassandra's binary protocol.

Get any driver from DataStax Academy downloads.

DataStax Enterprise 5.0 compatibility: You can use any DataStax driver that supports Apache Cassandra™ 3.0. However, to use new 5.0 functionality, such as DSE Graph, you must use the DataStax Enterprise specific drivers.

Available drivers