Version compatibility

Version compatibility tables for DataStax Enterprise and Apache Cassandra.

The DataStax drivers work exclusively with the Cassandra Query Language version 3 (CQL3) for transactional workloads and support both Fluent and String APIs for DSE Graph workloads. Use these drivers in production applications to pass CQL or DSE Graph statements from the client to a cluster and to retrieve, manipulate, or remove data. The C/C++, C#, Java, Node.js, PHP, Python, and Ruby drivers support Cassandra's binary protocol.

Get any driver from DataStax Academy downloads.

DataStax Enterprise 5.1 compatibility: You can use any DataStax driver that supports Apache Cassandra™ 3.1. However, to use functionality for DSE 5.1 and later, such as DSE Graph, you must use the DataStax Enterprise specific drivers.