Java drivers

When using the Java drivers with Apache Cassandra™ 4.0+ and the Java driver 3.x, you may encounter errors about protocol exceptions or dropped transport layer messages. Currently, the only solution is to upgrade the Java driver to version 4.13+.

DataStax Java Driver for Apache Cassandra

Icon legend

Icon Description

iconFullyCompatible

Fully compatible

iconPartiallyCompatible

Partially compatible

iconIncompatible

Incompatible

New features and bug fixes are developed on the latest minor version of the driver, and users are encouraged to stay current with those minor releases. APIs are maintained stable according to semantic versioning conventions, and upgrades should be trivial.

Earlier versions of DataStax Cassandra drivers did not have full support of DSE features.
Driver version Apache Cassandra version DataStax Enterprise version DataStax Astra

Version

4.x

3.x

2.2

2.1

6.8

6.7

6.0

5.1

5.0

Cloud

4.11+

iconFullyCompatible

iconFullyCompatible

iconFullyCompatible

iconFullyCompatible

iconFullyCompatible

iconFullyCompatible

iconFullyCompatible

iconFullyCompatible

iconFullyCompatible

iconFullyCompatible

4.5+

iconFullyCompatible

iconFullyCompatible

iconFullyCompatible

iconFullyCompatible

iconFullyCompatible

iconFullyCompatible

iconFullyCompatible

iconFullyCompatible

iconFullyCompatible

iconFullyCompatible

4.4+

iconPartiallyCompatible 4

iconFullyCompatible

iconFullyCompatible

iconFullyCompatible

iconPartiallyCompatible 4

iconFullyCompatible

iconFullyCompatible

iconFullyCompatible

iconFullyCompatible

iconFullyCompatible

4.3

iconPartiallyCompatible 4

iconFullyCompatible

iconFullyCompatible

iconFullyCompatible

iconPartiallyCompatible 1

iconPartiallyCompatible 1

iconPartiallyCompatible 1

iconPartiallyCompatible 1

iconPartiallyCompatible 1

iconFullyCompatible

4.0+

iconPartiallyCompatible 4

iconFullyCompatible

iconFullyCompatible

iconFullyCompatible

iconPartiallyCompatible 1

iconPartiallyCompatible 1

iconPartiallyCompatible 1

iconPartiallyCompatible 1

iconPartiallyCompatible 1

iconFullyCompatible

3.11

iconPartiallyCompatible 4

iconFullyCompatible

iconFullyCompatible

iconFullyCompatible

iconPartiallyCompatible 1

iconPartiallyCompatible 1

iconPartiallyCompatible 1

iconPartiallyCompatible 1

iconPartiallyCompatible 1

iconFullyCompatible

3.8+

iconPartiallyCompatible 4

iconFullyCompatible

iconFullyCompatible

iconFullyCompatible

iconPartiallyCompatible 1

iconPartiallyCompatible 1

iconPartiallyCompatible 1

iconPartiallyCompatible 1

iconPartiallyCompatible 1

iconFullyCompatible

3.0+

iconPartiallyCompatible 4

iconFullyCompatible

iconFullyCompatible

iconFullyCompatible

iconPartiallyCompatible 1

iconPartiallyCompatible 1

iconPartiallyCompatible 1

iconPartiallyCompatible 1

iconPartiallyCompatible 1

iconIncompatible

2.1

iconIncompatible 2

iconIncompatible 2

iconPartiallyCompatible 3

iconPartiallyCompatible 3

iconIncompatible 2

iconIncompatible 2

iconIncompatible 2

iconIncompatible 2

iconIncompatible 2

iconIncompatible

1. Earlier versions of DataStax Cassandra drivers did not have full support of DSE features.

2. Incompatible with Cassandra 3.0+ and DSE 5.0+; although it can execute requests, metadata is broken.

3. Limited to the Cassandra 2.1 API.

4. Limited to the Cassandra 3.x and 2.2.x API.

DataStax Enterprise Java Driver

DSE driver functionality has been merged, and is now developed in the open source DataStax drivers above.
Driver version DataStax Enterprise version DataStax Astra

Version

6.8

6.7

6.0

5.1

5.0

Cloud

2.3+

iconIncompatible 7

iconFullyCompatible

iconFullyCompatible

iconFullyCompatible

iconFullyCompatible

iconFullyCompatible

2.0+

iconIncompatible 7

iconFullyCompatible

iconFullyCompatible

iconFullyCompatible

iconFullyCompatible

iconIncompatible

1.9

iconIncompatible 7

iconFullyCompatible

iconFullyCompatible

iconFullyCompatible

iconFullyCompatible

iconFullyCompatible

1.6+

iconIncompatible 7

iconFullyCompatible

iconFullyCompatible

iconFullyCompatible

iconFullyCompatible

iconIncompatible

1.2+

iconPartiallyCompatible 5

iconPartiallyCompatible 5

iconPartiallyCompatible 5

iconFullyCompatible

iconFullyCompatible

iconIncompatible

1.1

iconPartiallyCompatible 6

iconPartiallyCompatible 6

iconPartiallyCompatible 6

iconPartiallyCompatible 6

iconFullyCompatible

iconIncompatible

5. Limited to DSE 5.1 API.

6. Limited to DSE 5.0 API.

7. The latest DSE 2.3 and 1.9 Java drivers partially work with DSE 6.8, but DSE 6.8 Graph features will not be available.