Node.js drivers

Driver compatibility tables for Node.js drivers.

DataStax Node.js Driver for Apache Cassandra®

Icon legend

Icon Description

iconFullyCompatible

Fully compatible

iconPartiallyCompatible

Partially compatible

iconIncompatible

Incompatible

New features and bug fixes are developed on the latest minor version of the driver, and users are encouraged to stay current with those minor releases. APIs are maintained stable according to semantic versioning conventions, and upgrades should be trivial.

Earlier versions of DataStax Cassandra drivers did not have full support of DSE features.
Driver version Apache Cassandra version DataStax Enterprise version DataStax Astra

Version

3.0+

2.2

2.1

6.8

6.7

6.0

5.1

5.0

Cloud

4.5

iconFullyCompatible

iconFullyCompatible

iconFullyCompatible

iconFullyCompatible

iconFullyCompatible

iconFullyCompatible

iconFullyCompatible

iconFullyCompatible

iconFullyCompatible

4.4

iconFullyCompatible

iconFullyCompatible

iconFullyCompatible

iconPartiallyCompatible 1

iconFullyCompatible

iconFullyCompatible

iconFullyCompatible

iconFullyCompatible

iconFullyCompatible

3.0+

iconFullyCompatible

iconFullyCompatible

iconFullyCompatible

iconPartiallyCompatible 1

iconPartiallyCompatible 1

iconPartiallyCompatible 1

iconPartiallyCompatible 1

iconPartiallyCompatible 1

iconIncompatible

  1. Earlier versions of DataStax Cassandra drivers did not have full support of DSE features.

DataStax Enterprise Node.js Driver

DSE driver functionality has been merged, and is now developed in the open source DataStax drivers above.
Driver version DataStax Enterprise version DataStax Astra

Version

6.8

6.7

6.0

5.1

5.0

Cloud

2.3+

iconPartiallyCompatible 4

iconFullyCompatible

iconFullyCompatible

iconFullyCompatible

iconFullyCompatible

iconFullyCompatible

1.6+

iconPartiallyCompatible 2

iconFullyCompatible

iconFullyCompatible

iconFullyCompatible

iconFullyCompatible

iconIncompatible

1.3+

iconPartiallyCompatible 2

iconPartiallyCompatible 2

iconPartiallyCompatible 2

iconFullyCompatible

iconFullyCompatible

iconIncompatible

1.0+

iconPartiallyCompatible 3

iconPartiallyCompatible 3

iconPartiallyCompatible 3

iconPartiallyCompatible 3

iconFullyCompatible

iconIncompatible

  1. Limited to DSE 5.1 API.

  2. Limited to DSE 5.0 API.

  3. Limited to DSE 6.7 API.