Ruby drivers

Driver compatibility tables for Ruby drivers.

DataStax Ruby Driver for Apache Cassandra®

Icon legend

Icon Description

iconFullyCompatible

Fully compatible

iconPartiallyCompatible

Partially compatible

iconIncompatible

Incompatible

New features and bug fixes are developed on the latest minor version of the driver, and users are encouraged to stay current with those minor releases. APIs are maintained stable according to semantic versioning conventions, and upgrades should be trivial.

Earlier versions of DataStax Cassandra drivers did not have full support of DSE features.
Driver version Apache Cassandra version DataStax Enterprise version DataStax Astra

Version

3.0+ 1 OSS

2.2

2.1

6.8

6.7

6.0

5.1

5.0

Cloud

3.0+

iconFullyCompatible

iconFullyCompatible

iconFullyCompatible

iconPartiallyCompatible 3

iconPartiallyCompatible 3

iconPartiallyCompatible 3

iconPartiallyCompatible 3

iconPartiallyCompatible 3

iconIncompatible

2.1

iconFullyCompatible

iconPartiallyCompatible 2

iconPartiallyCompatible 2

iconPartiallyCompatible 2

iconPartiallyCompatible 2

iconPartiallyCompatible 2

iconIncompatible

1.0+

iconPartiallyCompatible 2

iconPartiallyCompatible 2

iconPartiallyCompatible 2

iconPartiallyCompatible 2

iconPartiallyCompatible 2

iconPartiallyCompatible 2

iconIncompatible

  1. Limited to the Cassandra 2.0 API.

  2. While the OSS drivers are able to connect to DSE clusters, we strongly recommend upgrading to the DSE drivers in order to take full advantage of all DSE features.

DataStax Enterprise Ruby Driver

While the OSS drivers are able to connect to DSE clusters, we strongly recommend upgrading to the DSE drivers in order to take full advantage of all DSE features.
Driver version DataStax Enterprise version DataStax Astra

Version

6.7

6.0

5.1

5.0

4.8

Cloud

All versions

iconPartiallyCompatible 1

iconPartiallyCompatible 1

iconPartiallyCompatible 1

iconFullyCompatible

iconFullyCompatible

  1. Limited to the DSE 5.0 API.