Installing Starlight for JMS

Compatibility

The current version of Starlight for JMS is 2.x. Version 2.x includes:

  • Server side filtering

  • Upgraded Pulsar client compatibility to Pulsar 2.10

Wire protocol changes introduced in Pulsar 2.9 can cause compatibility issues when using Transactions.
To avoid issues, DataStax recommends using:

  • Pulsar JMS 1.x if your server is Pulsar 2.8.x or Luna Streaming 2.8.x

  • Pulsar JMS 2.x if your server is Pulsar 2.9.x, 2.10.x or Luna Streaming 2.10.x (or above)

Installation

Install Starlight for JMS by adding the following dependency to your Java Maven project pom.xml:

<dependency>
   <artifactId>pulsar-jms</artifactId>
   <groupId>com.datastax.oss</groupId>
   <version>1.0.0</version>
</dependency>

That file contains only Starlight for JMS code and transitively imports the Apache Pulsarâ„¢ client and the Jakarta JMS 2.0 specifications JAR.

You can also use a "fat" JAR that includes all dependencies:

<dependency>
   <artifactId>pulsar-jms-all</artifactId>
   <groupId>com.datastax.oss</groupId>
   <version>1.0.0</version>
</dependency>

Next