DataStax Docs

Documentation for installing, configuring, upgrading, and deploying DataStax products and helpful information for connecting with the DataStax community and other resources.

JDBC/ODBC drivers

Table 1. Driver download links plus installation and configuration documentation
Drivers (DSE 4.8 and later) DataStax instructions Simba install and configuration
DataStax ODBC Driver for Apache Cassandra and DataStax Enterprise with CQL connector. Download DataStax ODBC install documentation
Simba JDBC Driver for Apache Cassandra®. Download. Simba JDBC Driver for Apache Cassandra guide
Simba JDBC Driver for Apache Spark®. Download JDBC install documentation (in DSE Developer Guide) Simba JDBC Driver for Apache Spark guide
Simba ODBC Driver for Spark®. Download. ODBC install documentation (in DSE Developer Guide) Simba ODBC Driver for Spark guide

Spark Cassandra Connector

DSE Developer Guides Github
Getting started with the Spark Cassandra Connector 6.8 | 6.7 | 6.0 | 5.1 DataStax Spark Cassandra Connector

DataStax drivers for open-source Cassandra (OSS), DSE, and DDAC

Note: Starting January 2020, you can use the same DataStax driver for Apache Cassandra® (OSS), DataStax Enterprise, and DataStax Distribution of Apache Cassandra. DataStax has unified the DSE and OSS drivers to avoid user confusion and enhance the OSS drivers with some of the features in the DSE drivers. For more information, see the Better Drivers for Cassandra blog.
  • DSE drivers are supported until January 1st, 2022. However, all new features and functionality will take place only in the unified DataStax drivers.
Table 2. DataStax drivers for open-source Cassandra (OSS), DSE, and DDAC
Guides Source (GitHub) Version Compatibility Upgrade Quickstart
C++ (2.15.0) * C++ C++ C++ C++
C# (3.13.0) *

Graph extension

C# C# C# C#
Java (4.4.0) *

(includes Graph extension)

Java Java Java Java
Node.js (4.4.0) *

Graph extension

Node.js Node.js Node.js Node.js
Python (3.21.0) *

Graph extension (optional)

Python Python Python Python
* The starting versions for the unified drivers are indicated in parenthesis.

DSE maintenance only drivers

Note: DSE drivers are supported until January 1st, 2022. However, all new features and functionality will take place only in the unified DataStax drivers.
  • DSE only drivers require DSE 5.1 and later for full functionality.
Table 3. DSE drivers (only bug fixes will be included in new versions)
Driver Guides Graph Extensions Version compatibility
DSE C++ Guide DSE C++
DSE C# Guide DSE C# Graph Extension DSE C#
DSE Java Guide Included DSE Java
DSE Node.js Guide DSE Node.js Graph Extension DSE Node.js
DSE Python Guide DSE Python Graph Extension DSE Python

CQL to DSE version mapping

  • DSE 6.8 uses CQL 6.8
  • DSE 6.7 uses CQL 6.7
  • DSE 6.0 uses CQL 6.0
  • DSE 5.1 uses CQL 5.1

Studio notebooks

  • Studio 6.8 only supports DataStax Enterprise 6.8.
  • Studio 6.7 only supports DataStax Enterprise 6.7.
  • Studio 6.0 only supports DataStax Enterprise 6.0.
  • Studio 2.0 only supports DataStax Enterprise 5.1 and 5.0 (EOSL).
  • Notebooks created in earlier versions are automatically upgraded when starting later versions.

Welcome to DataStax docs

New products and docs
New Astra webinars and blogsBuild Cloud-Native Apps Migrate your Cassandra Apps for free DataStax for Developers pages Build your cloud-native applications with the Apache Cassandra® database.
Kubernetes Operator Automate deploying and managing Apache Cassandra or DataStax Enterprise. DataStax Desktop 2.2.0 Explore Cassandra 4.0 Beta in a development environment.
Katacoda scenarios now embedded within the docs to help you learn Cassandra and DataStax products. Best practices The most important things to know about using Cassandra and DataStax products.

DataStaxドキュメント

DataStax Japanese documentation: DataStaxドキュメント