Upgrading DSE OpsCenter

Considerations and procedures for upgrading OpsCenter.

Use the information in this section to upgrade OpsCenter from earlier versions.

Attention: Read and understand these instructions before upgrading. Carefully reviewing the planning and upgrading instructions can ensure a smooth upgrade and avoid pitfalls and frustrations
Important: For managing DataStax Enterprise (DSE) version 6.7 clusters, you must upgrade to DSE OpsCenter 6.7. See the following table for compatibility with DSE versions:
OpsCenter version DSE version
6.7 6.7, 6.0, 5.1
6.5 6.0, 5.1, 5.0
6.1 5.1, 5.0
6.0 5.0

OpsCenter uses definition files to enable support for multiple, supported versions of DSE without the need to immediately upgrade the currently installed version of OpsCenter. DataStax recommends keeping current with the latest major version releases to take advantage of new and improved features, enhanced performance, and fixed bugs or known issues.

In OpsCenter versions 6.1 and later, the OpsCenter and agent compatibility awareness feature notifies you of any potential features that might not operate on older agent versions.

Note: OpsCenter 6.0 and later does not support Apache Cassandra™. For more information, see DSE OpsCenter policy changes.