Upgrading DataStax drivers

Upgrading the DataStax C/C++, C#, Java, Node.js, PHP, Python, and Ruby drivers.

Important: Be sure to check driver compatibility. Depending on the driver version, you might need to recompile your client application code.
DataStax drivers come in two types:
  • DataStax drivers for DataStax Enterprise — for use by DSE 4.8 and later
  • DataStax drivers for Apache Cassandra™ — for use by Apache Cassandra™ and DSE 4.7 and earlier
Note: While the DataStax drivers for Apache Cassandra drivers can connect to DSE 5.0 and later clusters, DataStax strongly recommends upgrading to the DSE drivers. The DSE drivers provide functionality for all DataStax Enterprise features.

Information for upgrading is included in each driver guide:

DataStax drivers for DataStax Enterprise DataStax drivers for Apache Cassandra
C/C++ C/C++
C# C#
Java Java
Node.js Node.js
PHP PHP
Python Python
Ruby Ruby