以前のバージョンのDataStax Enterpriseのインストール

クラスター内のその他のノードと同じバージョンをインストールする手順。

DataStaxは、DataStax Enterprise 2.2.x以前のバージョンをインストールするためのバイナリーtarボールおよびパッケージ・バージョンを提供しています。

注: DataStax Enterprise 3.1より前のバージョンには、Oracle JRE 7またはJDK 7ではなくOracle JRE 6またはJDK 6を使用する必要があります。これらの以前のバージョンでは、JRE 7またはJDK 7をサポートしていません。

バイナリーtarボールからのインストール

tarボールをDataStax Enterpriseのダウンロードページからダウンロードして、関連ドキュメントのインストール手順に従います。

RHELベースまたはDebianベースのプラットフォームへのパッケージのインストール

関連ドキュメントのインストール手順に従い、インストール・コマンドで特定のバージョンを指定します。

RHELベースのプラットフォーム

形式:

sudo yum -y install dse-full-version-1

例:

sudo yum -y install dse-full-4.70.2-1

Debianベースのプラットフォーム

DataStaxリポジトリとリポジトリ・キーを定義したことを確認します。 ご使用のDataStax Enterpriseのバージョンのインストール手順を参照してください。

Aptitudeまたはapt-getを使用できます。

Aptitude

sudo aptitude install dse-full=[バージョン]
例:
sudo aptitude install dse-full=4.7.2-1
プロンプトが表示されたら、最初の2つのソリューションは受け入れず、3つ目のソリューションに「Y」と入力して受け入れます。
The following NEW packages will be installed:
dse-full{b} 
0 packages upgraded, 1 newly installed, 0 to remove and 309 not upgraded.
Need to get 10.3 kB of archives.After unpacking 53.2 kB will be used.
The following packages have unmet dependencies:
dse-full :Depends:dse (= 4.7.2-1) but it is not going to be installed.
Depends:dse-hive (= 4.7.2-1) but it is not going to be installed.
            ...
Depends:dse-libspark (= 4.7.2-1) but it is not going to be installed.
The following actions will resolve these dependencies:

Keep the following packages at their current version:
1) dse-full [Not Installed]                           

Accept this solution?[Y/n/q/?] n
The following actions will resolve these dependencies:

Install the following packages:          
1)  datastax-agent [5.1.3 (stable)]        
2)  dse [4.7.2-1 (stable)]                 
...           
16) dse-pig [4.7.2-1 (stable)]             

Accept this solution?[Y/n/q/?] n
The following actions will resolve these dependencies:

Install the following packages:          
1)  datastax-agent [5.1.2 (stable)]        
2)  dse [4.7.2-1 (stable)]                 
...      
16) dse-pig [4.7.2-1 (stable)]             

Accept this solution?[Y/n/q/?]Y
The following NEW packages will be installed:
datastax-agent{a} dse{a} dse-demos{a} dse-full dse-hive{a} dse-libcassandra{a} dse-libhadoop{a} dse-libhadoop-native{a} dse-libhive{a} dse-liblog4j{a} 
dse-libmahout{a} dse-libpig{a} dse-libsolr{a} dse-libspark{a} dse-libsqoop{a} dse-libtomcat{a} dse-pig{a} 
0 packages upgraded, 17 newly installed, 0 to remove and 309 not upgraded.
Need to get 554 MB of archives.After unpacking 672 MB will be used.
Do you want to continue?[Y/n/?]Y

apt-get

sudo apt-get install dse-full=[バージョン]-1 dse=[バージョン]-1 dse-hive=[バージョン]-1 dse-pig=[バージョン]-1 dse-demos=[バージョン]-1 dse-libsolr=[バージョン]-1 dse-libtomcat=[バージョン]-1 dse-libsqoop=[バージョン]-1 dse-liblog4j=[バージョン]-1 dse-libmahout=[バージョン]-1 dse-libhadoop-native=[バージョン]-1 dse-libcassandra=[バージョン]-1 dse-libhive=[バージョン]-1 dse-libpig=[バージョン]-1 dse-libhadoop=[バージョン]-1 dse-libspark=[バージョン]

例:

sudo apt-get install dse-full=4.7.2-1 dse=4.7.2-1 dse-hive=4.7.2-1 dse-pig=4.7.2-1 dse-demos=4.7.2-1 dse-libsolr=4.7.2-1 dse-libtomcat=4.7.2-1 dse-libsqoop=4.7.2-1 dse-liblog4j=4.7.2-1 dse-libmahout=4.7.2-1 dse-libhadoop-native=4.7.2-1 dse-libcassandra=4.7.2-1 dse-libhive=4.7.2-1 dse-libpig=4.7.2-1 dse-libhadoop=4.7.2-1 dse-libspark=4.7.2-1

インストールの詳細な手順については、ドキュメント版を参照してください。