Installing Simba JDBC Driver for Apache Cassandra

Steps for installing the Simba JDBC Driver for Apache Cassandra®.

Prerequisites

  • Your DSE license must include a license to use the Simba drivers.

  • Java Runtime Environment (JRE) 7.0 or 8.0 installed.

    • If you are using the driver with JDBC API version 4.2, or connecting to DataStax Astra databases, then you must use JRE 8.0.

  • Apache Cassandra versions 2.1 through 3.11.

Procedure

  1. Download the Simba JDBC Driver for Apache Cassandra from the DataStax Drivers Download page.

  2. Expand the ZIP file containing the driver.

  3. In your JDBC application, configure the following details:

    1. Add CassandraJDBC42.jar and the rest of the JAR files included in the ZIP file in your classpath.

    2. The JDBC driver class is com.simba.cassandra.jdbc42.Driver and the JDBC data source is com.simba.cassandra.jdbc42.DataSource.

      Support for JDBC 4.0 is deprecated.
    3. Set the connection URL to jdbc:cassandra://hostname:port where hostname is the hostname of the node on which AlwaysOn SQL is running, and port is the port number on which AlwaysOn SQL is listening.

      jdbc:cassandra://node1.example.com:10000

What’s next?