製品の互換性

さまざまな製品バージョン間の互換性とサポート状況。

DataStax Enterprise、Apache Cassandra、CQL、SSTableの互換性

次の表は、DataStax Enterprise(DSE)のサポート対象の各バージョンとそれに対応するApache Cassandra™、CQL、SSTableのバージョンを示しています。
DataStax Enterprise Cassandra CQL SSTable***
5.1 DSE実稼働動作保証済み3.10 + 機能強化 3.4 + 機能強化 m
5.0 3.0 + 機能強化 3.3
4.8 2.1 + 機能強化 3.1 k
販売終了(EOL)とサポート終了(EOSL)*    
4.7(EOL) 2.1 3.1 k
4.6(EOSL) 2.0(サポート対象外**) 3.1 j
4.5(EOSL) 2.0(サポート対象外**) 3.1  
4.0(EOSL**) 2.0(サポート対象外**) 3.1  
3.2(EOSL**) 1.2(サポート対象外**) 3.0**  
3.1(EOSL**) 1.2(サポート対象外**) 3.0**  
3.0(EOSL**) 1.1(サポート対象外**)    
2.2(EOSL**) 1.1(サポート対象外**)    
2.1(EOSL**) 1.0(サポート対象外**)    
2.0(EOSL**) 1.0(サポート対象外**)    
1.0(EOSL**) 1.0(サポート対象外**)    

*これらのバージョンのサポートには制限があります。「サポートされているソフトウェア」を参照してください。

**ドキュメントの保守期間が終了しています。「ドキュメントの保守」を参照してください。

***nodetool upgradesstablessstableloadersstableupgradeを使用する場合は、現在のDSEバージョンとの互換性を確認してください。表「SSTableの互換性とアップグレード・バージョン」を参照してください。

DataStax OpsCenterと、DSEおよびApache Cassandraの互換性

この表は、監視対象のクラスターとストレージ・クラスターが1つ以上使用されている場合の、両方のクラスターに関するOpsCenterの互換性を示しています。

OpsCenterバージョン DataStax Enterpriseバージョン Cassandraバージョン
6.1 4.8、5.0、5.1 サポート対象外。
6.0 4.7、4.8、5.0 サポート対象外。「DataStax OpsCenterのポリシー変更」を参照してください。
5.2 4.0、4.5、4.6、4.7、4.8 2.0、2.1
5.1.2、5.1.3、5.1.4 3.1、3.2、4.0、4.5、4.6、4.7 1.2、2.0、2.1
5.0.2、5.1.0、5.1.1 3.1、3.2、4.0、4.5、4.6 1.2、2.0
注: OpsCenterをバージョン4.xから5.2.xにアップグレードするには、まずバージョン5.1にアップグレードする必要があります。アップグレードするには、DataStaxサポートまでお問い合わせください。

DataStax StudioとDSEの互換性

次の表は、DataStax StudioとDSEの互換性を示しています。

Studioバージョン DSEバージョン
2.0 5.1、5.0
1.0.x 5.0

DataStaxドライバーと、DSEおよびApache Cassandraの互換性

ドライバー互換性マトリックス」を参照してください。

EOLおよびEOSLになっているDataStax OpsCenterソフトウェア

次の表は、EOL(販売終了)およびEOSL(サポート終了)になっているDataStax OpsCenterのバージョンを示しています。
OpsCenterバージョン 状況
5.2 EOSL**
5.1 EOSL**
5.0 EOSL**
4.1 EOSL**
4.0 EOSL**
3.1 EOSL**
3.0 EOSL**
2.1 EOSL**
2.0 EOSL**
1.4 EOSL**

*これらのバージョンのサポートには制限があります。

**ドキュメントの保守期間が終了しています。「ドキュメントの保守」を参照してください。

DataStaxによるApache Cassandraのサポート

DataStaxによる、DataStax CommunityバージョンのApache Cassandra™とApache Cassandra™のDataStaxディストリビューションのサポートは終了しました。使用可能な最新バージョンはCassandra 3.0.9とCassandra 3.9です。
  • 最新のオープンソース・バージョンをApache Cassandraからダウンロードしてください。
  • こちらのブログもご覧ください。

ドキュメントの保守

製品がEOSL(サポート終了)になると、その製品に関するドキュメントのアップデートは提供されなくなります。

DataStaxによる、DataStax CommunityバージョンのApache Cassandraと、Apache CassandraのDataStaxディストリビューションのサポートは終了しました。

一部のCassandraドキュメントはDataStaxによる保守期間が終了しています。最新のドキュメントについては、Apache CassandraのWebサイトを参照してください。DataStaxが作成している以下のCassandraドキュメントの最終更新日は2017年1月初旬です。

  • Cassandra 1.2
  • Cassandra 2.0
  • Cassandra 2.2(LinuxおよびWindows)
  • Cassandra 3.0(Windows)
  • Cassandra 3.x(LinuxおよびWindows)

DataStaxによるAMIのサポート

DataStaxによるDataStax ComboAMIの提供は終了しました。DataStax Enterpriseは次の2通りの方法でインストールできます。

AMIの信頼できる入手先

信頼できる入手先から入手した、サポートされているプラットフォームのAMIのみを使用してください。任意に入手したAMIはセキュリティ上のリスクをもたらし、EC2インストールの構成方法に起因して、予期しているよりもパフォーマンスが低い可能性があります。以下は、信頼できるAMIの例です。