サポートされているプラットフォーム

DataStax Enterprise、DataStax Studio、およびDSE OpsCenterでサポートされているオペレーティング・システム、JRE/JDK、ブラウザー。

重要: お使いのプラットフォームの販売終了ステータスを確認してください。EOSL版のJVMおよびオペレーティング・システムに対するDataStaxのサポートは終了しています。そのことを示すため、EOSL版はここに表示されています。

次のプラットフォームとバージョンはDataStaxによるサポート対象であり、DataStax製品との実稼働動作を保証するテストが実施されています。これ以外のプラットフォームまたはバージョンも動作する可能性がありますが、テストは実施されていません。

クラスターの統一に関する要件

各クラスター内のすべてのノードには、同じサブスクリプションを使用するように同じライセンスが付与されていなければなりません。たとえば、あるクラスターに5つのノードがある場合、そのクラスター内の5つのノードはすべてDataStax Basicであるか、すべてDataStax Enterpriseでなければなりません。1つのクラスター内に異なるサブスクリプションを混在させることはできません。「クラスター」とは、ソフトウェアを実行し、ゴシップを介して相互に通信し合うノードのコレクションであり、「ゴシップ」とは、関連するノードの相互通信を可能にするソフトウェア内のメカニズムです。詳細については、「エンタープライズ条件」を参照してください。

DataStax Enterprise 6.7、6.0、5.1、5.0でサポートされているプラットフォーム

オペレーティング・システム DSE 6.7(x86_64) DSE 6.0(x86_64) DSE 5.1(x86_64) DSE5.0(x86_64)
Amazon Linux
Amazon Linux AMI 2018.03

フル

パッケージ、tarボール

フル

パッケージ、tarボール

フル

パッケージ、tarボール、DataStaxインストーラー

フル(2016.09のみ)

パッケージ、tarボール、DataStaxインストーラー

Amazon Linux AMI 2016.09および2017.03

フル

パッケージ、tarボール

フル

パッケージ、tarボール

フル

パッケージ、tarボール、DataStaxインストーラー

フル(2016.09のみ)

パッケージ、tarボール、DataStaxインストーラー

Debian
Debian 9.x

フル

パッケージ、tarボール

フル

パッケージ、tarボール

フル

パッケージ、tarボール、DataStaxインストーラー

フル

パッケージ、tarボール、DataStaxインストーラー

Debian 8.x

フル

パッケージ、tarボール

フル

パッケージ、tarボール

フル

パッケージ、tarボール、DataStaxインストーラー

フル

パッケージ、tarボール、DataStaxインストーラー

Debian 7.x サポート対象外 サポート対象外 サポート対象外 サポート対象外
CentOS
CentOS 7.5

フル

パッケージ、tarボール

フル

パッケージ、tarボール

フル

パッケージ、tarボール

フル

パッケージ、tarボール

CentOS 7.4

フル

パッケージ、tarボール

フル

パッケージ、tarボール

フル

パッケージ、tarボール、DataStaxインストーラー

フル

パッケージ、tarボール、DataStaxインストーラー

CentOS 7.3

フル

パッケージ、tarボール

フル

パッケージ、tarボール

フル

パッケージ、tarボール、DataStaxインストーラー

フル

パッケージ、tarボール、DataStaxインストーラー

CentOS 7.2

フル

パッケージ、tarボール

フル

パッケージ、tarボール

フル

パッケージ、tarボール、DataStaxインストーラー

フル

パッケージ、tarボール、DataStaxインストーラー

CentOS 7.1

フル

パッケージ、tarボール

フル

パッケージ、tarボール

フル

パッケージ、tarボール、DataStaxインストーラー

フル

パッケージ、tarボール、DataStaxインストーラー

CentOS 6.10

フル

パッケージ、tarボール

フル

パッケージ、tarボール

フル

パッケージ、tarボール、DataStaxインストーラー

フル

パッケージ、tarボール、DataStaxインストーラー

CentOS 6.9

フル

パッケージ、tarボール

フル

パッケージ、tarボール

フル

パッケージ、tarボール、DataStaxインストーラー

フル

パッケージ、tarボール、DataStaxインストーラー

CentOS 6.8

フル

パッケージ、tarボール

フル

パッケージ、tarボール

フル

パッケージ、tarボール、DataStaxインストーラー

フル(5.0.2以降)

パッケージ、tarボール、DataStaxインストーラー

CentOS 6.7

フル

パッケージ、tarボール

フル

パッケージ、tarボール

フル

パッケージ、tarボール、DataStaxインストーラー

フル(5.0.2以降)

パッケージ、tarボール、DataStaxインストーラー

Mac OS X
10.11

開発者用

tarボール

開発者用

tarボール

開発者用

tarボール、DataStaxインストーラー

開発者用

tarボール、DataStaxインストーラー

10.10

開発者用

tarボール

開発者用

tarボール

開発者用

tarボール、DataStaxインストーラー

開発者用

tarボール、DataStaxインストーラー

10.9

開発者用

tarボール

開発者用

tarボール

開発者用

tarボール、DataStaxインストーラー

開発者用

tarボール、DataStaxインストーラー

Oracle Linux
Oracle Linux 6 Update 9

フル

パッケージ、tarボール

フル

パッケージ、tarボール

フル

パッケージ、tarボール

サポート対象外
Red Hat Enterprise Linux
Red Hat Enterprise Linux 7.5

フル

パッケージ、tarボール

フル

パッケージ、tarボール

フル

パッケージ、tarボール

フル

パッケージ、tarボール

Red Hat Enterprise Linux 7.4

フル

パッケージ、tarボール

フル

パッケージ、tarボール

フル

パッケージ、tarボール、DataStaxインストーラー

フル

パッケージ、tarボール、DataStaxインストーラー

Red Hat Enterprise Linux 7.3

フル

パッケージ、tarボール

フル

パッケージ、tarボール

フル

パッケージ、tarボール、DataStaxインストーラー

フル

パッケージ、tarボール、DataStaxインストーラー

Red Hat Enterprise Linux 7.2

フル

パッケージ、tarボール

フル

パッケージ、tarボール

フル

パッケージ、tarボール、DataStaxインストーラー

フル

パッケージ、tarボール、DataStaxインストーラー

Red Hat Enterprise Linux 7.1

フル

パッケージ、tarボール

フル

パッケージ、tarボール

フル

パッケージ、tarボール、DataStaxインストーラー

フル

パッケージ、tarボール、DataStaxインストーラー

Red Hat Enterprise Linux 6.10

フル

パッケージ、tarボール

フル

パッケージ、tarボール

フル

パッケージ、tarボール、DataStaxインストーラー

フル

パッケージ、tarボール、DataStaxインストーラー

Red Hat Enterprise Linux 6.9

フル

パッケージ、tarボール

フル

パッケージ、tarボール

フル

パッケージ、tarボール、DataStaxインストーラー

フル

パッケージ、tarボール、DataStaxインストーラー

Red Hat Enterprise Linux 6.8

フル

パッケージ、tarボール

フル

パッケージ、tarボール

フル

パッケージ、tarボール、DataStaxインストーラー

フル

パッケージ、tarボール、DataStaxインストーラー

Red Hat Enterprise Linux 6.7

フル

パッケージ、tarボール

フル

パッケージ、tarボール

フル

パッケージ、tarボール、DataStaxインストーラー

フル(5.0.2以降)

パッケージ、tarボール、DataStaxインストーラー

SUSE Linux Enterprise Server
SUSE Enterprise Linux 12

フル

tarボール

フル

tarボール

フル

tarボール

フル

tarボール

SUSE Enterprise Linux 11

フル

tarボール

フル

tarボール

フル

tarボール

フル

tarボール

Ubuntu(LTSリリースのみ)
Ubuntu LTS 16.04

フル

パッケージ、tarボール

フル

パッケージ、tarボール

フル

パッケージ、tarボール、DataStaxインストーラー

フル

パッケージ、tarボール、DataStaxインストーラー

Ubuntu LTS 14.04

フル

パッケージ、tarボール

フル

パッケージ、tarボール

フル

パッケージ、tarボール、DataStaxインストーラー

フル

パッケージ、tarボール、DataStaxインストーラー

Ubuntu LTS 12.04

フル

パッケージ、tarボール

フル

パッケージ、tarボール

フル

パッケージ、tarボール、DataStaxインストーラー

フル

パッケージ、tarボール、DataStaxインストーラー

OpsCenter 6.7、6.5、6.1、6.0でサポートされているプラットフォーム

オペレーティング・システム OpsCenter 6.7(x86_64) OpsCenter 6.5(x86_64) OpsCenter 6.1(x86_64)/ja/landing_page/doc/landing_page/supportedPlatforms.html#supportedPlatforms__os-check OpsCenter 6.0
Amazon Linux
Amazon Linux AMI 2016.09および2017.03

フル

パッケージ、tarボール

フル

パッケージ、tarボール

フル(6.1.5以降)

パッケージ、tarボール

LCMはサポート対象外

パッケージ、tarボール

Debian
Debian 9.x

フル

パッケージ、tarボール

フル

パッケージ、tarボール

フル

パッケージ、tarボール

フル

パッケージ、tarボール

Debian 8.x

フル

パッケージ、tarボール

フル

パッケージ、tarボール

フル

パッケージ、tarボール

フル

パッケージ、tarボール

Debian 7.x サポート対象外 サポート対象外 サポート対象外 サポート対象外
CentOS
CentOS 7.5

フル

パッケージ、tarボール

フル

パッケージ、tarボール

フル

パッケージ、tarボール

フル

パッケージ、tarボール

CentOS 7.4

フル

パッケージ、tarボール

フル

パッケージ、tarボール

フル

パッケージ、tarボール

フル

パッケージ、tarボール

CentOS 7.3

フル

パッケージ、tarボール

フル

パッケージ、tarボール

フル

パッケージ、tarボール

フル

パッケージ、tarボール

CentOS 7.2

フル

パッケージ、tarボール

フル

パッケージ、tarボール

フル

パッケージ、tarボール

フル

パッケージ、tarボール

CentOS 7.1

フル

パッケージ、tarボール

フル

パッケージ、tarボール

フル

パッケージ、tarボール

フル

パッケージ、tarボール

CentOS 6.10

フル

パッケージ、tarボール

フル

パッケージ、tarボール

フル

パッケージ、tarボール

サポート対象外
CentOS 6.9

フル

パッケージ、tarボール

フル

パッケージ、tarボール

フル

パッケージ、tarボール

サポート対象外
CentOS 6.8

フル

パッケージ、tarボール

フル

パッケージ、tarボール

フル

パッケージ、tarボール

フル(6.0.2以降)

パッケージ、tarボール

CentOS 6.7

フル

パッケージ、tarボール

フル

パッケージ、tarボール

フル

パッケージ、tarボール

フル(6.0.2以降)

パッケージ、tarボール

Mac OS X
10.11

開発者用

tarボール

開発者用

tarボール

開発者用

tarボール

10.10

開発者用

tarボール

開発者用

tarボール

開発者用

tarボール

10.9

開発者用

tarボール

開発者用

tarボール

開発者用

tarボール

Red Hat Enterprise Linux
Red Hat Enterprise Linux 7.4

フル

パッケージ、tarボール

フル

パッケージ、tarボール

フル

パッケージ、tarボール

フル

パッケージ、tarボール

Red Hat Enterprise Linux 7.3

フル

パッケージ、tarボール

フル

パッケージ、tarボール

フル

パッケージ、tarボール

フル

パッケージ、tarボール

Red Hat Enterprise Linux 7.2

フル

パッケージ、tarボール

フル

パッケージ、tarボール

フル

パッケージ、tarボール

フル

パッケージ、tarボール

Red Hat Enterprise Linux 7.1

フル

パッケージ、tarボール

フル

パッケージ、tarボール

フル

パッケージ、tarボール

フル

パッケージ、tarボール

Red Hat Enterprise Linux 6.10

フル

パッケージ、tarボール

フル

パッケージ、tarボール

フル

パッケージ、tarボール

フル

パッケージ、tarボール

Red Hat Enterprise Linux 6.9

フル

パッケージ、tarボール

フル

パッケージ、tarボール

フル

パッケージ、tarボール

サポート対象外
Red Hat Enterprise Linux 6.8

フル

パッケージ、tarボール

フル

パッケージ、tarボール

フル

パッケージ、tarボール

フル

パッケージ、tarボール

Red Hat Enterprise Linux 6.7

フル

パッケージ、tarボール

フル

パッケージ、tarボール

フル

パッケージ、tarボール

フル(6.0.2以降)

パッケージ、tarボール

SUSE Linux Enterprise Server
SUSE Enterprise Linux 12

OpsCenter LCMはサポート対象外

tarボール

OpsCenter LCMはサポート対象外

tarボール

OpsCenter LCMはサポート対象外

tarボール

OpsCenter LCMはサポート対象外

tarボール

SUSE Enterprise Linux 11

OpsCenter LCMはサポート対象外

tarボール

OpsCenter LCMはサポート対象外

tarボール

OpsCenter LCMはサポート対象外

tarボール

OpsCenter LCMはサポート対象外

tarボール

Ubuntu(LTSリリースのみ)
Ubuntu LTS 16.04

フル

パッケージ、tarボール

フル

パッケージ、tarボール

フル

パッケージ、tarボール

フル

パッケージ、tarボール

Ubuntu LTS 14.04

フル

パッケージ、tarボール

フル

パッケージ、tarボール

フル

パッケージ、tarボール

フル

パッケージ、tarボール

Ubuntu LTS 12.04

フル

パッケージ、tarボール

フル

パッケージ、tarボール

フル

パッケージ、tarボール

フル

パッケージ、tarボール

注: OpsCenter 6.1.3以降では、インストールするDSEのバージョンについてサポートされているOSプラットフォームのチェックがLCMにより自動的に実行されます。

DataStax製品でサポートされているJREとJDK

製品 OpenJDK Oracle JRE/JDK*
DataStax Enterprise
DSE 6.7、6.0 OpenJDK 8(1.8.0_151以降) Oracle Java 8(1.8.0_151以降)
DSE 5.1、5.0 OpenJDK 8(1.8.0_40以降) Oracle Java 8(1.8.0_40以降)
OpsCenter
OpsCenter 6.7、6.5、6.1、6.0 OpenJDK 8 Oracle Java 8(JDKまたはJRE)
DataStax Studio
Studio 6.7、6.0(Linux) OpenJDK 8 Oracle Java 8(1.8.0_151以降)
Studio 2.0(Linux) OpenJDK 8 Oracle Java 8(1.8.0_40以降)
Studio 2.0(Windows 7および10) Oracle Java 8
Studio 1.0 Oracle Java 8

* サポートされているOracle JREまたはJDK 8バージョンの最新ビルドの使用が推奨されます。

注: DSE 5.1.11および6.0.3以降、DataStaxではOpenJDK 8に対するより広範なテストを実施しています。この変更は、Oracle JRE/JDK 8のパブリック・アップデートの終了によるものです。「Oracle Java SEサポート・ロードマップ」を参照してください。

DSE OpsCenterとDataStax Studioでサポートされているブラウザー

ブラウザー DSE OpsCenter DataStax Studio**
Apple Safari あり Mac OS X 10.11、10.12、10.13
Google Chrome あり

Ubuntu 14.04 LTS、16.04 LTS Mac OS X 10.11、10.12、10.13、Windows 7、10、CentOS 7

Internet Explorer なし なし
Microsoft Edge なし なし
Mozilla Firefox あり

Ubuntu 14.04 LTS、16.04 LTS
Mac OS X 10.11、10.12、10.13
Windows 7、10
CentOS 6.8、7

** DataStax Studioは、各Webブラウザーの最新バージョンがインストールされている上記のプラットフォーム(すべて64ビット版)でテストを実施しています。

注: DataStax製品はビッグエンディアン・システムをサポートしていません。