DataStax documentation list

A list of all DataStax documentation.

Docker

  • Versions 4.8 and later

End-of-life (EOL)

  • Patches/bug fixes and support for EOL are not available. Some document changes are provided.
  • Versions 4.7 and earlier

Installing DataStax products

DataStax Enterprise (DSE)

Latest DataStax Enterprise Previous DataStax Enterprise Earlier DataStax Enterprise

DSE 6.7 Admin Guide | RN * | PDF | Zip

DSE 6.0 Admin Guide | RN * | PDF | Zip

DSE 5.1 Admin Guide | RN * | PDF | Zip

DSE 6.7 Architecture Guide | PDF | Zip

DSE 6.0 Architecture Guide | PDF | Zip

DSE 5.1 Architecture Guide | PDF | Zip

DSE 6.7 Developer Guide | RN * | PDF | Zip

DSE 6.0 Developer Guide | RN * | PDF | Zip

DSE 5.1 Developer Guide | RN * | PDF | Zip

DSE 5.0 | RN * | PDF | Zip

DSE OpsCenter

Note: To avoid confusion, the redirects for opscenter/latest, latest-opscenter, and latest-opsc have been removed. This was done because customers may not always be using the latest DSE OpsCenter version.
Latest DSE OpsCenter Previous OpsCenter Earlier OpsCenter

OpsCenter 6.7 | RN * | PDF | Zip

OpsCenter 6.5 | RN * | PDF | Zip

OpsCenter 6.1 | RN * | PDF | Zip

OpsCenter 6.0 | RN * | PDF | Zip

CQL (Cassandra Query Language)

Latest CQL Previous CQL Earlier CQL

CQL for DSE 6.7 | PDF | Zip

CQL for DSE 6.0 | PDF | Zip

CQL for DSE 5.1 | PDF | Zip

CQL 3.3 | PDF | Zip (for DSE 5.0 and Cassandra 3.0)

Docker

DSE note 1 OpsCenter note 1 Studio note 1

DataStax 6.7 Docker Guide

Docker for OpsCenter 6.7

Docker for DataStax Studio 6.7

DataStax 6.0 Docker Guide

Docker for OpsCenter 6.5

Docker for DataStax Studio 6.0

DataStax 5.1 Docker Guide

Docker for OpsCenter 6.1

Docker for DataStax Studio 2.0

DataStax drivers

Table 1. DataStax drivers for DataStax Enterprise note 7
C/C++ DSE driver | API docs Node.js DSE driver | API docs Python DSE Graph Extension | API docs
C# DSE driver | API docs Node.js DSE Graph Extension | API docs Ruby DSE driver
C# DSE Graph Extension | API docs PHP DSE driver | API docs Version compatibility
Java DSE driver | API docs Python DSE driver | API docs
Note: While the DataStax drivers for Apache Cassandra drivers can connect to DSE 5.0 and later clusters, DataStax strongly recommends upgrading to the DSE drivers. The DSE drivers provide functionality for all DataStax Enterprise features.
Table 2. DataStax drivers for Apache Cassandra™ note 8
C/C++ OSS driver Node.js OSS driver Ruby OSS driver
C# OSS driver PHP OSS driver Version compatibility
Java OSS driver Python OSS driver

Apache Cassandra™

DataStax Distribution of Apache Cassandra Cassandra used by DSE 5.0 (EOL)

DataStax Distribution of Apache Cassandra | PDF | Zip

Based on DataStax Enterprise 5.1 and Apache Cassandra 3.11.

Cassandra 3.0 (Linux) | PDF | Zip

Other Cassandra versions are not supported.

End-of-Service-Life and unsupported products

Patches/bug fixes, support, and documentation updates for EOSL and unsupported products are not available.

Table 3. DataStax Enterprise end-of-service- life (EOSL)

DSE 4.8 | PDF | Zip

Playlist tutorial | PDF | Zip for DSE 4.8 and Cassandra 2.1

DSE 4.7 | Zip

DSE 4.6 | Zip

DSE 4.5 | Zip

DSE 4.0 | Zip

DSE 3.2 | Zip

DSE 3.1 | PDF

DSE 3.0 | PDF

DSE 2.2 | PDF

DSE 2.1 | PDF

DSE 2.0 | PDF

DSE 1.0 | PDF

Table 4. Unsupported DSE OpsCenter

OpsCenter 5.2 | Zip

OpsCenter 5.1 | Zip

OpsCenter 5.0 | Zip

OpsCenter 4.1 | Zip

OpsCenter 4.0 | Zip

OpsCenter 3.2 | PDF

OpsCenter 3.1 | PDF

OpsCenter 2.1 | PDF

OpsCenter 2.0 | PDF

OpsCenter 1.4 | PDF

Table 5. Open source Apache Cassandra documentation not supported or maintained by DataStax

Cassandra 2.1 | PDF | Zip

Cassandra 3.0 (Windows) | Zip

Cassandra 3.x (Linux) | Zip

Cassandra 3.x (Windows) | Zip

Cassandra 2.2 (Linux) | Zip

Cassandra 2.2 (Windows) | Zip

Cassandra 2.0 | Zip

Cassandra 1.2 | Zip

Cassandra 1.1 | PDF

Cassandra 1.0 | PDF

Cassandra 0.8

Cassandra 0.7

Cassandra 0.6

Table 6. Unsupported CQL

CQL 3.1 | PDF | Zip (for DSE 4.0, 4.5, 4.6, 4.7, 4.8; Cassandra 2.0, 2.1)

CQL 3.x | Zip (for Cassandra 2.2 and 3.x)

CQL 3.0 | Zip (for DSE 3.1, 3.2; Cassandra 1.2)

Table 7. Unsupported Drivers and other DataStax products
Unsupported drivers Other products

OBDC driver

DataStax DevCenter

Compatible with DataStax Enterprise (DSE) versions up to 5.0.

DataStax Studio 1.0 | Zip