Java drivers

Driver compatibility tables for Java drivers.

DataStax Enterprise Java Driver

Icon legend

Driver version DataStax Enterprise version
Version 6.0 5.1 5.0 4.8
1.7
1.6
1.5 2
1.4 2
1.3 2
1.2 2
1.1 1 1

1Limited to DSE 5.0 API.

2Limited to DSE 5.1 API.

DataStax Java Driver for Apache Cassandra™

Icon legend

Driver version Apache Cassandra version DataStax Enterprise version
Version 3.0 2.2 2.1 6.0 5.1 5.0 4.8
3.6 1 1 1
3.5 1 1 1
3.4 1 1 1
3.3 1 1 1
3.2 1 1 1
3.1 1 1 1
3.0 1 1 1
2.1 2 3 3 2 2 2
2.0 2 4 4 2 2 2 4

1While the OSS drivers are able to connect to DSE clusters, DataStax strongly recommends upgrading to the DSE drivers in order to take full advantage of all DSE features.

2Driver is incompatible with Cassandra 3.0. Although it can execute requests, metadata is broken.

3Limited to the Cassandra 2.1 API.

4Limited to the Cassandra 2.0 API.

Table 1. Matrix table icons legend
Icon Description
Latest stable version actively maintained
Fully compatible.
Partially compatible.
Incompatible
New features and bug fixes are developed on the latest minor version of the driver, and users are encouraged to stay current with those minor releases. APIs are maintained stable according to semantic versioning conventions, and upgrades should be trivial.