すべてのDataStaxドキュメント

新旧バージョンおよびアーカイブされたDataStaxドキュメントの一覧

DataStaxが作成した新旧バージョンおよびアーカイブされたドキュメントの一覧

新製品

表 1.
DataStax Astra AWS DataStax Astra GCP DataStax Kubernetes Operator for Apache Cassandra® DataStax Storage Attached Indexベータ

DataStax Enterprise

表 2. サポートされているDSEバージョンのドキュメント
DSE 6.8(最新) DSE 6.7(1つ前) DSE 6.0 & 5.1(旧)

DSE 6.8インストール・ガイド: HTML | PDF | Zip

DSE 6.7インストール・ガイド:HTML | PDF | Zip

DSE 6.0インストール・ガイド:HTML | PDF | Zip

DSE 5.1インストール・ガイド:HTML | PDF | Zip

DSE 6.8管理者ガイド:HTML | リリース・ノート | PDF | Zip

DSE 6.7管理者ガイド:HTML | リリース・ノート | PDF | Zip

DSE 6.0管理者ガイド:HTML | リリース・ノート | PDF | Zip

DSE 5.1管理者ガイド:HTML | リリース・ノート | PDF | Zip

DSE 6.8アーキテクチャー・ガイド:HTML | PDF | Zip

DSE 6.7アーキテクチャー・ガイド:HTML | PDF | Zip

DSE 6.0アーキテクチャー・ガイド:HTML | PDF | Zip

DSE 5.1アーキテクチャー・ガイド:HTML | PDF | Zip

DSE 6.8開発者ガイド:HTML | リリース・ノート | PDF | Zip

DSE 6.7開発者ガイド:HTML | リリース・ノート | PDF | Zip

DSE 6.0開発者ガイド:HTML | リリース・ノート | PDF | Zip

DSE 5.1開発者ガイド:HTML | リリース・ノート | PDF | Zip

DSEセキュリティ・ガイド6.8: HTML | PDF | Zip

DSEセキュリティ・ガイド6.7:HTML | PDF | Zip

DSEセキュリティ・ガイド6.0:HTML | PDF | Zip

DSEセキュリティ・ガイド5.1:HTML | PDF | Zip

オープンソースのApache Cassandra®(OSS)

注: DataStaxには、Apache Cassandra用のさまざまなドキュメントバージョンがあります。詳細については、「Apache Cassandraの他のドキュメントのバージョンについて」を参照してください。
表 3. オープンソースのApache CassandraおよびCQLドキュメント
Apache Cassandra(OSS) 対応するCQL
OSS 3.x(3.1~3.9):HTML | PDF | Zip CQL 3.x:HTML | PDF | Zip
OSS 3.0:HTML | PDF | Zip CQL 3.3:HTML | PDF | Zip
OSS 2.2:HTML | PDF | Zip CQL 3.x:HTML | PDF | Zip
OSS 2.1:HTML | PDF | Zip CQL 3.1:HTML | PDF | Zip

DSE OpsCenter

注: 混乱を避けるため、opscenter/latestlatest-opscenterlatest-opscのリダイレクトは削除されました。お客様が最新バージョンのDSE OpsCenterを使用しているとは限らないことから、この処置が行われました。
表 4. サポートされているOpsCenterバージョンのドキュメント
OpsCenter 6.8(最新) OpsCenter 6.7(1つ前) 以前のOpsCenter 6.5および6.1(旧)

OpsCenter 6.8インストール・ガイド:HTML | PDF | Zip

OpsCenter 6.7インストール・ガイド:HTML | PDF | Zip

OpsCenter 6.5インストール・ガイド:HTML | PDF | Zip

OpsCenter 6.1インストール・ガイド:HTML | PDF | Zip

OpsCenter 6.8:HTML | リリース・ノート | PDF | Zip

OpsCenter 6.7:HTML | リリース・ノート | PDF | Zip

OpsCenter 6.5:HTML | リリース・ノート | PDF | Zip

OpsCenter 6.1:HTML | リリース・ノート | PDF | Zip

CQL(Cassandra Query Language)

表 5. サポートされているCQLバージョンのドキュメント
CQL 6.8(最新) CQL 6.7(1つ前) CQL 6.0および5.1(旧)

CQL for DSE 6.8:HTML | PDF | Zip

CQL for DSE 6.7:HTML | PDF | Zip

CQL for DSE 6.0:HTML | PDF | Zip

CQL for DSE 5.1:HTML | PDF | Zip

CQLSHスタンドアロン・ツールHTML | PDF | Zip CQLSHスタンドアロン・ツール | HTML | PDF | Zip CQLSHスタンドアロン・ツールHTML | PDF | Zip

Studio

表 6. サポートされているStudioバージョンのドキュメント

DataStax Studio 6.8:HTML | リリース・ノート | PDF | Zip

DataStax Studio 6.7:HTML | リリース・ノート | PDF | Zip

DataStax Studio 6.0:HTML | リリース・ノート | PDF | Zip

DataStax Studio 2.0:HTML | リリース・ノート | Zip

Docker

表 7. サポートされるバージョンのDataStax Dockerのドキュメント
Docker 6.7 Docker 6.7 Docker 6.0 Docker 5.1

DataStax DSE 6.8 Dockerガイド:HTML

DataStax DSE 6.7 Dockerガイド:HTML

DataStax DSE 6.0 Dockerガイド:HTML

DataStax DSE 5.1 Dockerガイド:HTML

Docker for OpsCenter 6.8:HTML

Docker for OpsCenter 6.7:HTML

Docker for OpsCenter 6.5:HTML

Docker for OpsCenter 6.1:HTML

Docker for DataStax Studio 6.8:HTML

Docker for DataStax Studio 6.7:HTML

Docker for DataStax Studio 6.0:HTML

Docker for DataStax Studio 2.0:HTML

DataStaxドライバー

注: 2020年1月から、Apache Cassandra®(OSS)、DataStax Enterprise、およびDataStax Distribution of Apache Cassandraに同じDataStaxドライバーを使用できるようになりました。DataStaxは、ユーザーの混乱を避け、DSEドライバーの一部の機能でOSSドライバーを強化するために、DSEとOSSドライバーを統合しました。詳細については、「Better Drivers for Cassandra」ブログ(英語)を参照してください。
  • DSEドライバーは、2022年1月1日までサポートされます。ただし、すべての新機能は統合DataStaxドライバーでのみ使用できます。
表 8. オープンソースのCassandra(OSS)、DSE、およびDDACのDataStaxドライバー
ガイド ソース(GitHub) バージョンの互換性 アップグレード Quickstart
C++(2.15.0)* C++ C++ C++ C++
C#(3.13.0)*

Graph拡張機能

C# C# C# C#
Java(4.4.0)*

(Graph拡張機能を含む)

Java Java Java Java
Node.js(4.4.0)*

Graph拡張機能

Node.js Node.js Node.js Node.js
Python(3.21.0)*

Graph拡張機能(オプション)

Python Python Python Python
*かっこ内は統合ドライバーの開始バージョンです。
表 9. DSEドライバー(新しいバージョンにはバグ修正のみが含まれます)
ドライバー・ガイド Graph拡張機能 バージョンの互換性
DSE C++ガイド DSE C++
DSE C# Guide DSE C# Graph拡張機能 DSE C#
DSE Javaガイド 含む DSE Java
DSE Node.jsガイド DSE Node.js Graph拡張機能 DSE Node.js
DSE Pythonガイド DSE Python Graph拡張機能 DSE Python
表 10. PHPおよびRubyメンテナンス専用ドライバー(新しいバージョンには重要なバグ修正のみが含まれます)
DSEドライバー・ガイド DDAC/OSSドライバー・ガイド DSEバージョンの互換性 DDAC/OSSバージョンの互換性
PHP PHP DSE PHP OSS PHP
Ruby Ruby DSE Ruby OSS Ruby

JDBC/ODBCドライバー

表 11. ドライバーのダウンロード・リンクとインストールおよび構成ドキュメント
ドライバー(DSE 4.8以降) DataStaxの手順 Simbaのインストールと構成
CQLコネクターを使用するApache CassandraとDataStax Enterprise用のDataStax ODBCドライバー。ダウンロード DataStax ODBCインストール・ドキュメント
Apache Cassandra®®用Simba JDBC ドライバー。ダウンロード. JDBC Simbaドキュメント
Apache Spark®用Simba JDBCドライバー。ダウンロード JDBCインストール・ドキュメントDSE開発者ガイド内 JDBC Simbaドキュメント
Spark®用Simba ODBCドライバー。ダウンロード ODBCインストール・ドキュメントDSE開発者ガイド内 ODBC Simbaドキュメント

データ・ローダー

DataStax Apache Kafka Connector DataStax Bulk Loader DSE Graph Loader(DSE 5.1~6.7を含む)

インストール・ガイド:HTML | PDF | Zip

リリース・ノート:HTML

ガイド:HTML | PDF | Zip

インストール・ガイド:HTML | PDF | Zip

リリース・ノート:HTML

ガイド:HTML | PDF | Zip

6.7 | 6.0 | 5.1

DataStax Distribution of Apache Cassandra®(DDAC)

DDACは、DSE 5.1以降のCassandraの拡張機能を含む、オープンソースのApache Cassandra 3.11と完全に互換性があります。
注: DataStaxには、Apache Cassandra用のさまざまなドキュメントバージョンがあります。詳細については、「Apache Cassandraの他のドキュメントのバージョンについて」を参照してください。
表 12. サポートされているDDACバージョンのドキュメント
DDAC CQL for DDAC DDACセキュリティ

DDAC:HTML | PDF | Zip

管理者、アーキテクチャー、および開発者情報を含む

CQL for DDAC:HTML | PDF | Zip

CQLSHスタンドアロン・ツールHTML | PDF | Zip

DDACセキュリティ:HTML | PDF | Zip

その他のDataStaxガイド

表 13. DSEおよびDDACの使用方法に関連するガイド

DataStaxデスクトップ:HTMLラボ) | PDF | Zip

アップグレード・ガイド:HTML | PDF | Zip

DSE計画イド:HTML | PDF | Zip

DSEトラブルシューティング・ガイド:HTML | PDF | Zip

サポート終了およびサポート対象外の製品(以前のドキュメント)

EOSLおよび対象外の製品のパッチ/バグの修正、サポート、およびドキュメント更新は利用できません。これらのドキュメントは、アーカイブされているため更新されません。

表 14. サポートが終了した(EOSL)DataStax Enterprise

DSE 5.0: HTML | Zip

DSE 4.8:HTML | Zip

DSE 4.7:HTML | Zip

DSE 4.6:HTML | Zip

DSE 4.5:HTML | Zip

DSE 4.0:HTML | Zip

DSE 3.2:HTML | Zip

DSE 3.1: HTML | PDF

DSE 3.0:HTML | PDF

DSE 2.2:HTML | PDF

DSE 2.1:HTML | PDF

DSE 2.0:HTML | PDF

DSE 1.0:HTML | PDF

プレイリスト・チュートリアル:HTML | PDF | Zip(DSE 4.8およびCassandra 2.1用)

Kerberosチュートリアル:HTML | PDF | Zip

表 15. サポート対象外のDSE OpsCenter

OpsCenter 6.0:HTML | Zip

OpsCenter 5.2:HTML | Zip

OpsCenter 5.1:HTML | Zip

OpsCenter 5.0:HTML | Zip

OpsCenter 4.1:HTML | Zip

OpsCenter 4.0:HTML | Zip

OpsCenter 3.2:HTML | PDF

OpsCenter 3.1:HTML | PDF

OpsCenter 2.1:HTML | PDF

OpsCenter 2.0: | PDF

OpsCenter 1.4:PDF

表 16. DSEリリースに含まれていたCassandraドキュメント(DataStaxによるサポートまたは保守は終了)
Cassandra 3.xおよび3.0(Linux) Cassandra 2.x(Linux) Cassandra 1.x(Linux) Cassandra(Windows) 初期のCassandra

Cassandra 3.0:HTML | Zip

Cassandra 2.2:HTML | Zip

Cassandra 1.2:HTML | Zip

Cassandra 3.0:HTML | Zip

Cassandra 0.8:HTML

Cassandra 3.x(Linux):HTML | Zip

Cassandra 2.1:HTML | PDF | Zip

Cassandra 1.1:HTML | PDF

Cassandra 3.x:HTML | Zip

Cassandra 0.7:HTML

Cassandra 2.0:HTML | Zip

Cassandra 1.0:HTML | PDF

Cassandra 2.2:HTML | Zip

Cassandra 0.6:HTML
表 17. DSEリリースに含まれていたCQLドキュメント(DataStaxによるサポートまたは保守は終了)

CQL 3.3:HTML | Zip(DSE 5.0およびCassandra 3.0用)

CQL 3.1:HTML | Zip(DSE 4.0、4.5、4.6、4.7、4.8およびCassandra 2.0、2.1用)

CQL 3.0:HTML | Zip(DSE 3.1、3.2、およびCassandra 1.2用)

CQL 3.x:HTML | Zip(Cassandra 2.2および3.x用)

表 18. 保守が終了したその他のドキュメント

OBDCドライバー:HTML

DataStax DevCenter:HTML

バージョン5.0以下のDSEと互換性があります。

DataStax Studio 1.0:HTML | Zip