Installing DataStax Enterprise 5.0.x patch releases 

DataStax provides GUI/Text installers, binary tarballs, and Debian and RHEL packages for installing previous patch releases of DataStax Enterprise 5.0.x.

The latest version of DataStax Enterprise is 5.0.10.

To view the available patch releases for DataStax Enterprise 5.0, see the 5.0 Release Notes.

For earlier versions, see Installing DataStax Enterprise 4.8 and earlier.

Installing DataStax Enterprise 5.0.x from the binary tarball 

When installing from the binary tarball, you can either download the tarball and then extract the files, or use curl.

Downloading and extracting the tarball
  1. Using your DataStax Academy credentials, download the tarball from:
  2. Extract the files:
    $ tar -xzvf dse-version_number.tar.gz
    For example:
    $ tar -xzvf dse-5.0.2.tar.gz

    For more information, see the installation instructions for your version.

Using curl

Use the following curl command to download and install DataStax Enterprise:

$ curl --user dsa_email_address:password -L https://downloads.datastax.com/enterprise/dse-version_number-bin.tar.gz | tar xz
For example:
$ curl --user daenerys@targaryen.com:Dothraki_warlord -L https://downloads.datastax.com/enterprise/dse-4.8.8-bin.tar.gz | tar xz

Installing DataStax Enterprise 5.0.x from the RHEL packages 

  1. If needed, add the DataStax Yum repository and enable signature verification, as described in the documentation for your version.
  2. Install DataStax Enterprise specifying the version:
    $ sudo yum -y install dse-full-version_number-1
    For example:
    $ sudo yum -y install dse-full-5.0.2-1

For additional instructions, see the documentation version for your installation.

Installing DataStax Enterprise 5.0.x from the Debian packages 

  1. If needed, add the DataStax repository file and key for your version, as described in the documentation for your version.
  2. Install DataStax Enterprise specifying the version:
    $ sudo apt-get install dse-full=version_number-1 dse=version_number-1 dse-hive=version_number-1 dse-pig=version_number-1 dse-demos=version_number-1 dse-libsolr=version_number-1 dse-libtomcat=version_number-1 dse-libsqoop=version_number-1 dse-liblog4j=version_number-1 dse-libmahout=version_number-1 dse-libhadoop-native=version_number-1 dse-libcassandra=version_number-1 dse-libhive=version_number-1 dse-libpig=version_number-1 dse-libhadoop=version_number-1 dse-libspark=version_number
    For example:
    $ sudo apt-get install dse-full=5.0.2-1 dse=5.0.2-1 dse-hive=5.0.2-1 dse-pig=5.0.2-1 dse-demos=5.0.2-1 dse-libsolr=5.0.2-1 dse-libtomcat=5.0.2-1 dse-libsqoop=5.0.2-1 dse-liblog4j=5.0.2-1 dse-libmahout=5.0.2-1 dse-libhadoop-native=5.0.2-1 dse-libcassandra=5.0.2-1 dse-libhive=5.0.2-1 dse-libpig=5.0.2-1 dse-libhadoop=5.0.2-1 dse-libspark=5.0.2-1 dse-libgraph=5.0.2-1 dse-libhadoop2-client=5.0.2-1 dse-libhadoop2-client-native=5.0.2-1
    Attention: Be sure to specify all the packages; otherwise, the installation might fail.

For additional instructions, see the documentation version for your installation.

Installing DataStax Enterprise 4.8 and earlier 

The Release notes provide information about the available patch releases.
Release notes Installation instructions
4.8 4.8
4.7 4.7
4.6 4.6
4.5 4.5